Machine virtuelle

Posez vos questions logiciels ici !
Règles du forum
Lorsqu'un problème est résolu, merci d'indiquer (RÉSOLU) à la fin du titre

Ce forum s'adresse à des personnes qui débutent. Merci d'éviter le langage "Geek" ou les réponses en mode "Terminal" lorsqu'il y a existe des réponses en mode "Graphique".
cn099
Messages : 2
Inscription : 06 sept. 2017, 12:43

Machine virtuelle

Message par cn099 » 06 sept. 2017, 12:54

Bonjour,
J'essaie d'installer une machine virtuelle. J'ai installé VirtualBox et Vagrant via la logithèque, et j'utilise puphpet pour créer le fichier vagrantfile. Malheureusement, lorsque je lance la commande vagrant up dans la console, j'obtiens le message d'erreur suivant :

The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!
/sbin/ifdown eth1 2> /dev/null
Stdout from the command:
Stderr from the command:

D'après mes recherches sur internet, eth1 n'existe pas sur xubuntu... ou quelque chose comme ça.
Quelqu'un.e aurait une idée sur la façon de résoudre ce problème ?
Merci et bonne journée

Avatar de l’utilisateur
naga
Administrateur
Messages : 250
Inscription : 20 juin 2013, 16:23

Re: Machine virtuelle

Message par naga » 06 sept. 2017, 13:48

Re,

Il semble que Vagrant est un Bug en 1.8.1 (la version proposée sur xubuntu 16.04). Ce bug a été remonté ici : https://github.com/mitchellh/vagrant/issues/7155

Il semble être corrigé dans la dernière version (1.9.8), téléchargeable ici : https://www.vagrantup.com/downloads.html (en debian, 64 bit, si tu es sur xubuntu).

En cliquant sur le .deb téléchargé (toujours faire cela avec un fichier téléchargé sur le site d'origine d'un logiciel !!), il remplacera l'ancien en s'installant par la logithèque, et quand les futures versions proposées dépasseront la 1.9.8, alors, les mises à jour se feront dessus.

Merci à SethVargo qui a fait la correction ;) https://github.com/mitchellh/vagrant/co ... c16f471fa4

D'autres personnes ont contourné le souci en passant par des base boxes comme Bento (car il s'agit d'un bug de boxes, pas de vagrant en soi même) https://github.com/chef/bento, mais installer la version la plus récente de Vagrant devrait suffire ;)

Ce bug est déjà remonté aux développeurs. Il y a d'autres pistes au cas où tu ai besoin, sinon, merci de nous en informer.

Bonne journée.
Association Nâga
Reconditionnement d'ordinateur sur Nantes Métropole
https://www.naga44.org/

:!: Merci d'indiquer les sujets comme "résolu" (à la fin du titre du premier message), une fois qu'il le sont.

Répondre